News Flash:
New Version of ShopClass theme 1.4.0 is Released on 13 JUNE 2018, Please upgrade your installation.

Sitemap not not generating new entries

Please post bugs you have found in tuffclassified theme. If you have fix for that post it too.
Do not post anything else, issue related to third party plugins should not be posted here.
steve
Senior
Posts: 222
Joined: Thu Oct 01, 2015 5:33 pm
Has thanked: 11 times
Been thanked: 4 times

Sitemap not not generating new entries

Post by steve » Wed Jul 20, 2016 8:54 pm

Hi Nabvjot,

I recently saw that my sitemap is not generating new entries.. infact the last update was made on april on my sitemapindex.xml
And the entries in there are very less.
Is this a bug? How can i check whats wrong?

Thanks

User avatar
tuffadmin
Site Admin
Posts: 1236
Joined: Tue Jan 29, 2013 7:31 pm
Has thanked: 33 times
Been thanked: 111 times

Re: Sitemap not not generating new entries

Post by tuffadmin » Thu Jul 21, 2016 7:38 pm

what cron setting you have chosen.
No support for unnecessary PM, use forum for support queries.
Please give us good review if you bought our theme from Osclass Market

steve
Senior
Posts: 222
Joined: Thu Oct 01, 2015 5:33 pm
Has thanked: 11 times
Been thanked: 4 times

Re: Sitemap not not generating new entries

Post by steve » Fri Jul 22, 2016 2:55 pm

tuffadmin wrote:
Thu Jul 21, 2016 7:38 pm
what cron setting you have chosen.
On "crontab -e" i get -

@hourly /usr/bin/indexer --rotate --config /etc/sphinxsearch/sphinx.conf --all

This is the only thing i have on my crontab -e

User avatar
tuffadmin
Site Admin
Posts: 1236
Joined: Tue Jan 29, 2013 7:31 pm
Has thanked: 33 times
Been thanked: 111 times

Re: Sitemap not not generating new entries

Post by tuffadmin » Fri Jul 22, 2016 5:09 pm

I was asking cron setting in sitemap setting page.
No support for unnecessary PM, use forum for support queries.
Please give us good review if you bought our theme from Osclass Market

steve
Senior
Posts: 222
Joined: Thu Oct 01, 2015 5:33 pm
Has thanked: 11 times
Been thanked: 4 times

Re: Sitemap not not generating new entries

Post by steve » Fri Jul 22, 2016 6:04 pm

I don't see a cron option on my sitemap settings. Please see my screenshot below
sitemap.png
You do not have the required permissions to view the files attached to this post.

User avatar
tuffadmin
Site Admin
Posts: 1236
Joined: Tue Jan 29, 2013 7:31 pm
Has thanked: 33 times
Been thanked: 111 times

Re: Sitemap not not generating new entries

Post by tuffadmin » Fri Jul 22, 2016 7:41 pm

You are using older version, please upgrade to latest version of tuffclassified theme.
Old version has issue with with osclass cron.
No support for unnecessary PM, use forum for support queries.
Please give us good review if you bought our theme from Osclass Market

steve
Senior
Posts: 222
Joined: Thu Oct 01, 2015 5:33 pm
Has thanked: 11 times
Been thanked: 4 times

Re: Sitemap not not generating new entries

Post by steve » Fri Jul 22, 2016 11:32 pm

tuffadmin wrote:
Fri Jul 22, 2016 7:41 pm
You are using older version, please upgrade to latest version of tuffclassified theme.
Old version has issue with with osclass cron.
There are too many modifications i've done on the website, and i prefer to wait for the new shopclass theme rather modify tuffclassified's new version again.

Can you give a quick fix for this one please?
Thanks

User avatar
tuffadmin
Site Admin
Posts: 1236
Joined: Tue Jan 29, 2013 7:31 pm
Has thanked: 33 times
Been thanked: 111 times

Re: Sitemap not not generating new entries

Post by tuffadmin » Fri Jul 22, 2016 11:52 pm

Add this code in your theme function file.

Code: Select all

osc_add_hook('cron_weekly', 'generate_sitemap');
No support for unnecessary PM, use forum for support queries.
Please give us good review if you bought our theme from Osclass Market

steve
Senior
Posts: 222
Joined: Thu Oct 01, 2015 5:33 pm
Has thanked: 11 times
Been thanked: 4 times

Re: Sitemap not not generating new entries

Post by steve » Sat Jul 23, 2016 2:25 am

Ok, doing that now.
As for the options on the sitemap settings, what is the "recommended" settings? Should i check on the categories, cities etc checkboxes?

steve
Senior
Posts: 222
Joined: Thu Oct 01, 2015 5:33 pm
Has thanked: 11 times
Been thanked: 4 times

Re: Sitemap not not generating new entries

Post by steve » Mon Jul 25, 2016 11:07 pm

That worked, the sitemap started generating entries.
As for the options on the sitemap settings, what is the "recommended" settings? Should i check on the categories, cities etc checkboxes?
Thanks!

Locked