News Flash:
New Version of ShopClass theme 1.4.0 is Released on 13 JUNE 2018, Please upgrade your installation.

User Uploaded Images No Longer Working

If you are having general problems with ShopClass theme, post your questions here. This is not the place for customization or feature requests
pfrink25
Beginner
Posts: 12
Joined: Sat May 12, 2018 12:17 pm
Location: Hilliard, Ohio
Has thanked: 1 time
Contact:

User Uploaded Images No Longer Working

Post by pfrink25 » Wed May 30, 2018 4:27 am

Within the past four days, my website is no longer allowing images to be uploaded when a registered user goes to publish a new listing.

I get the following error message:
Upload Failed
Upload failure reason unknown

I have tried multiple images, logged in as multiple users, different categories, different devices, etc. with no luck. Everything was working fine. I checked with my hosting provider there have been no changes to my server: i.e. php updates, hosting changes, etc. I have not made any changes to my server and checked all my files to see what has changed, to no help.

I have the latest version of all the plugins, themes, and, OSClass that is available. I am currently using the ShopClass theme; but, I tried testing with other themes as well with the same error message being received. I am able to upload images on the admin side; but, not as a logged in user which is a huge issue. I've scowered through the support forums for the theme and OsClass for four days and I have not found a solution to why it isn't working anymore.

Has anyone else occurred this error? Any suggestions and assistance would be greatly appreciated.
I really do not want to go to square one and start all over again, as this has been several months long in the process to get to this point.

I am also getting this message in my debug:

[Tue May 29 19:23:45 2018] [warn] [client 172.12.205.200] mod_fcgid: stderr: PHP Parse error: syntax error, unexpected end of file in /home/pfrink25/ForSaleHilliard/oc-content/themes/shopclass/main.php on line 41, referer: https://forsalehilliard.com/item/new

But the files in main.php are the standard ones that came with the ShopClass theme with no error until now.
You do not have the required permissions to view the files attached to this post.

pfrink25
Beginner
Posts: 12
Joined: Sat May 12, 2018 12:17 pm
Location: Hilliard, Ohio
Has thanked: 1 time
Contact:

Re: User Uploaded Images No Longer Working

Post by pfrink25 » Wed May 30, 2018 4:40 am

I overlooked another error I am getting:

[Tue May 29 19:25:17 2018] [error] [client 172.12.205.200] ModSecurity: Rule 7fcdc1b083d8 [id "390801"][file "/dh/apache2/template/etc/mod_sec2/50_asl_rootkits.conf"][line "45"] - Execution error - PCRE limits exceeded (-8): (null). [hostname "forsalehilliard.com"] [uri "/oc-admin/index.php"] [unique_id "Ww4Lja3sjPMAAAQVkfEAAAAC"]

I have uninstalled and reinstalled the theme I am using multiple times in addition to trying out Bender and other themes to see if I got the same error message. Unfortunately, I am still unable to upload files as a logged in user trying to post a new listing.

Thank you everyone for looking this over for me. All the insight and direction is greatly appreciated. I'm really trying to avoid doing a complete reinstall and loosing all my hard work.

User avatar
tuffadmin
Site Admin
Posts: 1236
Joined: Tue Jan 29, 2013 7:31 pm
Has thanked: 33 times
Been thanked: 111 times

Re: User Uploaded Images No Longer Working

Post by tuffadmin » Wed May 30, 2018 6:37 am

Is this working with other theme.
No support for unnecessary PM, use forum for support queries.
Please give us good review if you bought our theme from Osclass Market

User avatar
tuffadmin
Site Admin
Posts: 1236
Joined: Tue Jan 29, 2013 7:31 pm
Has thanked: 33 times
Been thanked: 111 times

Re: User Uploaded Images No Longer Working

Post by tuffadmin » Wed May 30, 2018 7:37 am

I also need access to your error logs.
No support for unnecessary PM, use forum for support queries.
Please give us good review if you bought our theme from Osclass Market

pfrink25
Beginner
Posts: 12
Joined: Sat May 12, 2018 12:17 pm
Location: Hilliard, Ohio
Has thanked: 1 time
Contact:

Re: User Uploaded Images No Longer Working

Post by pfrink25 » Wed May 30, 2018 2:11 pm

It is giving the error across every theme now. It still lets me upload files in the admin area under manage listings.

@tuffadmin, I'm sending you a private message with login details I created for you to look behind the scenes.

pfrink25
Beginner
Posts: 12
Joined: Sat May 12, 2018 12:17 pm
Location: Hilliard, Ohio
Has thanked: 1 time
Contact:

Re: User Uploaded Images No Longer Working

Post by pfrink25 » Wed May 30, 2018 10:51 pm

I tried an switching to an older version and turning mod_security off. Making these changes did not fix the issue either. :cry:

pfrink25
Beginner
Posts: 12
Joined: Sat May 12, 2018 12:17 pm
Location: Hilliard, Ohio
Has thanked: 1 time
Contact:

Re: User Uploaded Images No Longer Working

Post by pfrink25 » Thu May 31, 2018 2:23 am

It is a 100% not the server. I have another domain on the same server with OsClass already running and it was setup around the same time I set this site up. This site is still up and running and allows pictures to be uploaded by users for new listings. I must have changed something; and, I have no idea what it could of been to cause only this error and no other problems.

I will keep trouble shooting and trying to hunt it down. Thank you again everyone for their help! I will keep you posted when I figure it out. If anyone else has any ideas or suggestions and has gone through something similar, please let me know!

You are all fantastic and I am glad to have such a great support group from all of you! :) :D :) :D

User avatar
tuffadmin
Site Admin
Posts: 1236
Joined: Tue Jan 29, 2013 7:31 pm
Has thanked: 33 times
Been thanked: 111 times

Re: User Uploaded Images No Longer Working

Post by tuffadmin » Thu May 31, 2018 6:26 am

180531-0001.png
My log directory is empty, you can also send logs through email.
You do not have the required permissions to view the files attached to this post.
No support for unnecessary PM, use forum for support queries.
Please give us good review if you bought our theme from Osclass Market

pfrink25
Beginner
Posts: 12
Joined: Sat May 12, 2018 12:17 pm
Location: Hilliard, Ohio
Has thanked: 1 time
Contact:

Re: User Uploaded Images No Longer Working

Post by pfrink25 » Thu May 31, 2018 3:58 pm

I have been unable to locate the issue to rectify the upload issue. I am doing a launch of the site in a few weeks to my local community; so, I have a tight timetable I am trying to keep. I think it is time to move on and start over. :'(

I have decided at this point I am going to have to do a complete reinstall of the standard files. Is it okay to just replace the files on my server now with the original site files or is it recommended that I erase everything, start a fresh install, and, then change the config file back to what it is now?

User avatar
tuffadmin
Site Admin
Posts: 1236
Joined: Tue Jan 29, 2013 7:31 pm
Has thanked: 33 times
Been thanked: 111 times

Re: User Uploaded Images No Longer Working

Post by tuffadmin » Thu May 31, 2018 4:42 pm

Backup your upload directory and database.
No support for unnecessary PM, use forum for support queries.
Please give us good review if you bought our theme from Osclass Market

Post Reply